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INTRODUCTION TO VERSA DIRECTOR
The Versa Networks lab environment consists of a fixed, pre-configured topology that will allow you to explore, configure, and 
manage Versa Networks CPEs by using Versa Director, the central management and orchestration platform for a Versa Secure SD-
WAN solution. After completing this lab, you will be able to: 

•	 Identify the functions of the main Versa Director tabs; and
•	 Navigate through the Versa Director environment to accomplish some basic tasks

In this lab, you will be assigned to a lab environment with 2 CPEs and a hub site. Your user will be a single tenant in a multi-tenant 
system, so the hub device will be shared device.

The lab environment is accessed through Amazon Workspaces. For instructor-led courses, your instructor will provide information on 
how to connect to the lab environment.

The remote desktop connection opens a remote workstation, where you will use various tools to navigate and configure the lab 
environment. The main tool you will use in this lab is Versa Director. Versa Director can be accessed by opening the Google Chrome 
browser on the Remote Desktop. There is a bookmark to the Versa Director device in the Google Chrome bookmark bar.

During certain lab parts, the lab guide will present sample output from the GUI or the CLI. The sample outputs are SAMPLES and 
represent the information as it appeared during the lab guide creation. Your output may vary in some ways (some devices may or may 
not be present, some routes may or may not be the same, etc.) Do not be alarmed if your results vary slightly from the results shown in 
the lab guide. The important thing is that the lab functions in the desired manner.

This lab guide will step you through some common tasks that are performed on Versa Director. After an introductory set of exercises, 
you will be asked to perform some basic tasks that will allow you to become more familiar with the environment.

The goal of this and all lab exercises is to help you gain additional skills and knowledge. Because of this, the lab guide contains 
additional instruction to supplement the student guides.

Now that we’ve discussed what is expected, let’s get started!
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EXERCISE 1: IDENTIFY THE MAIN COMPONENTS OF VERSA 
DIRECTOR
Please refer to the Lab Access Guide for instructions on how to connect to the remote lab environment.

Step 1.	 Explore Versa Director

 a.	 In the remote landing station, open the Google Chrome browser and log into Versa Director. The Versa Director 
IP address is https://10.27.1.10 in the remote browser. You should be placed into the Administration > Appliances 
dashboard of Versa Director. 
 
There are 5 tabs at the top of the Versa Director user interface. Each of the tabs represents a set of dashboards to 
perform certain tasks, such as monitoring devices, managing configuration components on Versa Director, and creating 
and managing different components. The currently selected tab is highlighted automatically: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The Appliances table of the Administration dashboard lists all of the deployed appliances in your SD-WAN 
environment. You can click on a device in the list to navigate directly to that device’s configuration and monitoring 
dashboard. You can also navigate to the individual device configuration and management dashboard by clicking the 
Monitor tab. 
 
The primary tabs are: 

•	 Director View: Access to Versa Director configuration and management
•	 Appliance View: Access to individual appliances
•	 Template View: Access to the configuration templates

The primary Director View tabs are: 

•	 Monitor: Provides access to device specific statistics, status, and configurations
•	 Configuration: Provides access to configuration components stored on Versa Director, including Device 

Groups, Bind Data, and Device and Service Templates
•	  Workflows: Provides access to create new workflows and to view and update existing workflows
•	 Administration: Provides access to SD-WAN environment configuration, including device inventory, deploy-

ment information, overlay configuration, external connectors, organization definition and configuration, user 
management, and licensing. It also provides access to the software management features, such as downloaded 
OS packages, Security Packages (Spacks), etc.

•	 Analytics: Opens the Versa Analytics GUI within Versa Director
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Because you’re already here, let’s explore the Administration tab.

The menu on the left displays the main categories of administration information. Wherever you see a > symbol, this means that the 
category can be expanded:

 b.	 Expand the Connectors menu.

The Connectors menu lists the different types of connections that are available to other systems, such as Analytics 
clusters, authentication servers, syslog servers, and so forth.

As a tenant of a managed system, Versa Director hides many of these options from the tenant user and only 
displays configuration components that can be managed by the sub-tenant. This prevents sub-tenants from making 
configuration changes that could have a negative impact on other tenants. However, from an administrator login, all 
of the options for Analytics and connector configuration are present.

Tenant User View
Administrator User View
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 c.	 Next expand the System menu.

The System menu is where Versa Director system information is configured, including Versa Director High 
Availability, NTP servers, the Versa Director license, DNS settings, Time Zone settings, and so forth. It’s important 
to remember that the Versa Director is a computer system that may need to perform functions for the local processes, 
including DNS lookups and local routing. These settings are NOT for the SD-WAN systems. These settings are for 
the local Versa Director system.

Because Versa Director is owned and managed by the provider (in a multi-tenant system), only a provider 
administrator has access to the server settings. The system properties that can be managed by the tenants include 
Single Sign On features for authentication to Versa Director.

 d.	 Expand the Inventory menu.

Here you will see dashboards to manage the software images stored on Versa Director, the current device inventory, 
which includes devices that have been created in the Versa Director database (Hardware), Security Package 
management, OS Security package management, and uCPE images. The Unknown Devices dashboard lists 
appliances that have been onboarded but that have a serial number that does not match a device serial number in 
the Hardware table. Again, depending on whether the user is connected as a provider admin, or a tenant admin, the 
options are displayed.

Admin

Tenant
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 e.	 Expand the SDWAN > Settings menu.

The SDWAN Settings dashboard is where the SD-WAN overlay address scheme is defined.

Step 2.	 Explore Versa Director
In this lab exercise, you will explore various dashboards of the Versa Director platform and answer questions related to the areas 
that you explore. This exploration is from the perspective of a tenant in a multi-tenant system. Your user ID is assigned a role of 
TenantSuperAdmin.

 a.	 Navigate to the Configuration tab.

Use the GUI to find where configuration templates are stored.

SD-WAN settings are only configurable by a 
service provider Administrator account

1

2

3
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 b.	 Open the Devices > Devices menu

Use the GUI to show where the device related configuration is stored.

 c.	 Open the Workflows dashboard

A workflow is a step-by-step process to perform a task. In Versa Director, a workflow is a step-by-step process to 
create something, similar to a configuration wizard. The process or settings used are saved so that the process can be 
repeated, or so that settings in the original process can be changed and re-used to update or modify the object that 
the workflow created.

Navigate to the Workflows tab. In the Workflows tab, examine the different types of workflows that can be used to 
create configuration components.

1

2

3

Note: Sub-tenants cannot create controllers, 
as controllers are part of the provider 
organization.
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 d.	 Open the Monitor tab.

In the Monitor tab there is a left-side menu and a sub-menu at the top of the table displayed on the page.

 e.	 Open the Devices tab.

The Devices tab displays the devices that are managed by your organization.

Note that when you click on a device, the top level menu changes to Appliance View. If you click on the “Total 
Appliances” tab, the top level menu changes back to Director View.

Organization Menu
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 f.	 Open the Administration panel in Director View.

 Click the Director View button at the top of the administration panel.

 g.	 Navigate to the Director User Management dashboard.

In the Administration tab, locate the Director User Management menu on the left side and expand the menu. Select 
the Organization > Users from the menu.

Organization users are users that have permission to log into Versa Director and view/configure information 
associated with the specific organization. Provider users are available to users that are logged in with a provider 
administrator account.

Tenants can manage their own users and access, and providers can manage all users and access to the system.
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From the user menu, user accounts can be locked or unlocked. A user account may become locked because of 
unsuccessful login attempts, or because the administrator manually locks the account. You can use the Lock/Unlock 
buttons to set the user account mode.

 h.	 Explore the Inventory menu.

Expand the Inventory menu, then select Software Images from the list. This is where software images are stored 
when they are downloaded to Versa Director. Software images are placed in their proper categories: OS Security 
Packages, Security Packages, and VOS/Director images. The software packages in the libraries can be used for 
appliance and director upgrades.

Tenants cannot download software packages, as that may affect system storage. Providers in a multi-tenant system 
can download software packages, and those software packages are available to tenants for installation.
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 i.	 Select the Inventory > Hardware menu.

The Inventory > Hardware dashboard is where devices that have been created in Versa Director are stored. It’s 
important to remember that when you create a device in Versa Director, it is stored as an object in the Versa Director 
database.

The Hardware table lists devices that have been created in Versa Director. The Appliances menu table lists devices 
that have been deployed and are active in the network. When a device in the Hardware table is onboarded or 
deployed in the network, a corresponding Appliance is created in the Appliance table – but only AFTER the device 
is successfully onboarded and is live.

You can click on an item in the hardware table to view the properties associated with the device.
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Key Point: The Organization drop-down controls the information displayed in the dashboards. Information displayed is associated 
with the selected organization. This is consistent across all dashboards.
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 j.	 Open the Analytics dashboard.

Analytics stores recorded information from the environment and can be accessed directly from the Analytics tab in 
Versa Director, or through the Analytics GUI directly.

•	 Logs: Logging and triggered events from VOS devices
•	 Dashboard: Statistics gathered from devices and reported to Versa Analytics

On many of the dashboards you can hover your mouse over a chart or device name and further details will be 
displayed:
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 k.	 Hover your mouse over the B01 device in the Top sites by bandwidth chart to view the bandwidth information for the 
B01 branch.

 l.	 Click the B01 chart section to open the B01 bandwidth analysis dashboard.

You can see the link usage over time in the chart. The time can be adjusted for different time periods.
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 m.	 Change the time frame from Last day to Last hour to view how the time display changes.

 n.	 Click the Availability tab to view the site’s availability over time.

Take a few minutes to navigate through each of the site’s statistics tabs to see what information is stored on each tab.

Note: Some charts may display “No data to display” because this is a lab environment, and traffic is not actively 
passing between sites. As labs proceed, more information may be available in the dashboards.
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 o.	 Select the System dashboard to view information about the appliance health.

 p.	 Click on an appliance name to see more details about that appliance.

STOP! Notify your instructor that you have completed this lab.STOP
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VERSA WORKFLOWS AND TEMPLATES
The Versa Networks lab environment consists of a fixed, pre-configured topology that will allow you to explore, configure, and 
manage Versa Networks CPEs by using Versa Director, the central management and orchestration platform for a Versa Secure SD-
WAN solution. After completing this lab, you will be able to:

•	 Create a configuration template using template workflows;
•	 Create a new device group;
•	 Re-assign your devices to the new device group, thereby re-assigning your devices to a new device template;
•	 Commit the new template to your devices;
•	 Verify the services enabled in a configuration template and on the devices;
•	 Clone a template workflow and verify the creation of a corresponding device template; and
•	 Clone a device template and verify the creation of a corresponding template workflow.

In this lab you will be assigned two CPE devices (Branch devices) for configuration and monitoring. The branch devices are named 
after the student ID that you have been assigned.

The lab environment is accessed through Amazon Workspaces. Your student ID and workspace will be assigned by the instructor.

The remote desktop connection opens a remote workstation, where you will use various tools to navigate and configure the lab 
environment. The main tool you will use in this lab is Versa Director. Versa Director can be accessed by opening the Google Chrome 
browser on the Remote Desktop. The IP address of the Versa Director (from the remote workstation) is 10.27.1.10. Once you begin the 
lab, you may want to create a bookmark to Versa Director in the web browser on the remote desktop.

During certain lab parts, the lab guide will present sample output from the GUI or the CLI. The sample outputs are SAMPLES and 
represent the information as it appeared during the lab guide creation. Your output may vary in some ways (some devices may or may 
not be present, some routes may or may not be the same, etc.) Do not be alarmed if your results vary slightly from the results shown in 
the lab guide. The important thing is that the lab functions in the desired manner.

This lab guide will step you through some common tasks that are performed on Versa Director. After an introductory set of exercises, 
you will be asked to perform some basic tasks that will allow you to become more familiar with the environment.

The goal of this and all lab exercises is to help you gain additional skills and knowledge. Because of this, the lab guide contains 
additional instruction to supplement the student guides.

Now that we’ve discussed what is expected, let’s get started!
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Step 1.	 Connect to the Remote Desktop

In the following lab exercises, you will:

•	 Connect to the AWS workspace to launch the remote desktop connection;
•	 Launch the Google Chrome browser in the remote desktop; and
•	 Log into Versa Director on the remote desktop.

 a.	 Connect to the remote desktop.

Open your local browser and connect to: https://clients.amazonworkspaces.com/ In the Amazon Workspaces 
window, select the Web Access link to open a web-based remote desktop session.

 b.	 Enter the registration code provided by your instructor, then click Register.

 c.	 Once registered, click the Sign In button to log into the workspace and start the remote desktop session.



(C) Versa 2025

Versa Networks Lab Guide:
SD-WAN Configuration and Administration

18

 d.	 Open Google Chrome on the remote desktop.

On the remote desktop, locate and double-click the Google Chrome icon on the desktop to start the browser. You can 
start the browser from the icon on the desktop or from the icon on the task bar.

There may be a bookmark in the remote browser window. If there is a bookmark, use the bookmark to connect to 
Versa Director. If there is not a bookmark, the IP address of Versa Director is 10.27.1.10.
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Step 2.	

 a.	 Log Into Versa Director

Log into Versa Director with the username and password provided by the instructor. The default login is your 
student ID (e.g. Student01, Student02, Studnet03, etc.) with the password Versa@123.

You should be placed on the Administration > Appliances dashboard, where the appliances in your organization are 
displayed.

 b.	 Open your Branch01 device (B01)

In the Administration > Appliances tab, locate your SxxB01 branch device (where Sxx is your tenant ID assigned by 
your instructor.)



(C) Versa 2025

Versa Networks Lab Guide:
SD-WAN Configuration and Administration

20

 c.	 Verify the security services enabled on the device.

Open the Configuration > Services dashboard to view the type of security services that are enabled on the device. 
You should see that Next Gen Firewall is the security service available on this device.

 d.	 Expand the Security services menu.

Click on the arrow next to Next Gen Firewall to expand the list of services currently available on the device.

 e.	 Click the Director View button to exit Appliance View and return to Director View.

To exit appliance mode, click on the Director View tab. This will take you back to the main view that allows you to 
perform centralized management tasks. Note how the top menu bar changes when you change back to Director view.
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Step 3.	 View the Device Workflows

 a.	 From Director View, navigate to Workflows > Devices > Devices to view the device workflows that have been created 
in Versa Director. 

 b.	 View the Branch B01 Device Workflow.

Click on the workflow associated with Branch 01 (B01)

The workflow has a set of steps that are designed to walk you through the process of defining a device. These steps 
are: Basic > Location Information > Device Service Template > Bind Data > Review. For this lab, we will focus on 
the Basic tab, as that is where the device group association is configured. The device should be associated with the 
DG-Sxx-NGFW device group, as shown.
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Step 4.	 View the Configuration database

 a.	 Navigate to the Configure dashboard to view the configuration components stored in Versa Director.

 b.	 In the Configuration dashboard, navigate to Devices > Device Groups to view the configured device groups.

The device groups are displayed. The devices that are associated with each device group are displayed on the right-
hand side. You can see that both devices are assigned to the DG-Sxx-NGFW device group.

Note: Although you can re-assign devices to different device groups within the configuration dashboard, the re-
assignment of a device to a different device group does NOT change the device group assignment within the device 
workflow. It is recommended to make device group assignments through the corresponding device workflow to 
maintain consistency.

Click on the DG-Sxx-NGFW device group to see its properties.

Within the device group, locate the Post 
 Staging Template drop-down menu. The  
device group is linked to the  
Sxx_Template_NGFW device template.

 c.	 Click Cancel to close the device group window.
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Step 5.	 Create a new template using a Template Workflow

 a.	 Navigate to Workflows > Template > Templates dashboard to view the device template workflows that were used to 
create the existing device configuration templates.

 b.	 Add a new Template Workflow

In the Template Workflow dashboard, click the + Add button to create a new template workflow. Name the new 
workflow Sxx-Template-New, where Sxx is the student ID that was assigned to you.
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 c.	 Assign the Name, Solution Tier, and Service Bandwidth as shown:

 d.	 Set the Organization and Firewall Services

Scroll down to the Organizations box and select your organization (student number) in the drop-down menu, then 
select Stateful Firewall in the Firewall Services drop-down menu.

When you select the organization, the list of controllers available to that organization automatically populate in the 
Controllers dialog next to the Organizations dialog. You should see Controller-01 auto-populate in the Controllers 
list.

 e.	 Select the Analytics Cluster

Locate the Analytics & Software Version box. In the Analytics Cluster drop-down, select Analytics. This will 
configure the template to send all statistics and log messages on the VOS devices to the Analytics cluster.
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Step 6.	 Assign Port Roles

 a.	 Click the Next button to continue to the Device Port Configuration dashboard.

 b.	 In the Device Port Configuration dialog, you will configure ports 0, 1, and 2. Ports 0 and 1 will be WAN ports, and port 
2 will be a LAN port. Click on a port icon to assign the port a role.

 c.	 Assign Port Roles

When a role is assigned to a port, the port configuration dialog appears. Assign the following roles to the ports:

•	 Port 0: WAN port; Assigned to network INET
•	 Port 1: WAN port: Assigned to network MPLS
•	 Port 2: LAN port: Assigned to network Student_LAN
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Note: Variables for bind data are created based on the names of the networks. If you use the same network name for the LAN port 
in all of your sample configurations in the lab, the existing bind data associated with the LAN port will be applied to the LAN port 
regardless of what template is used. If a template has a different name for the Network name, you will have to re-enter the LAN 
IP addresses for all of the devices to fill in the new bind-data variable. If you have a question about what the LAN name is, you 
can cancel the workflow process, open an existing workflow, and copy the LAN network name. Then restart the device template 
configuration and paste the same network name on the LAN port.

 d.	 Configure the LAN port

The LAN port configuration should associate the LAN port with your student LAN VR (e.g. Student01-LAN-VR, 
Student02-LAN-VR, etc.). The name of the LAN network should be Student_LAN.
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 e.	 Verify the port role configuration

Verify the final port role configuration. Your results should resemble the below configuration examples.

WAN Ports

LAN Port
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Step 7.	 Create a DIA connection in the Tunnels dashboard

 a.	 Click the Next button to continue to the Tunnels dialog.

 b.	 In the Tunnels dialog, locate the Split Tunnels section. The Split Tunnels section allows you to create a bridge between 
a LAN VRF and a WAN Virtual Router.

 c.	 Bridge the LAN VRF to the INET WAN

To create a DIA bridge between the INET WAN and the LAN VRF:

•	 Select the StudentXX-LAN-VR from the VRF Names drop-down.
•	 Select INET in the WAN Interfaces drop-down.
•	 Mark the Direct Internet Access check box
•	 Click the blue + button on the far right
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Step 8.	 Examine the Routing Dialog

 a.	 Click the Next button to continue to the Routing dialog.

The Routing dialog allows you to create basic routing protocol configuration within virtual routers. The options 
are BGP, OSPF, and Static routing. This creates a basic routing configuration and basic policies to advertise locally 
learned routes to the SD-WAN, and SD-WAN learned routes into the routing protocols that are configured here. 
While the Workflow routing protocol configuration is basic, once the protocols are configured you can modify the 
protocol configuration within the device template for more advanced configurations.

Do not configure any routing protocols in this lab.
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Step 9.	 Examine the Inbound NAT dialog

 a.	 Click the Next button to navigate to the  dialog.

The Inbound NAT dialog allows you to configure static inbound (destination) NAT, which can be useful if you have 
internal resources that must be made available to public networks. Inbound traffic will be translated to the private IP 
address specified.

Do not configure any Inbound NAT settings.
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Step 10.	 Examine the Management Servers dialog.

 a.	 Click Next to navigate to the Management Servers dialog.

The Management Servers dialog allows you to configure connections to additional management processes, such as 
NTP servers, authentication servers, SNMP managers, etc.

Do not configure any management servers settings.
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Step 11.	 Review the Template Workflow and Deploy

 a.	 Click the Next button to navigate to the Review window.

 b.	 The Review dialog displays a review of the parameters that have been configured for the template.

Step 12.	 Deploy the Workflow
Click the Deploy button to save and deploy the workflow. A workflow that has been saved only does not create a 
corresponding template. A workflow that has been deployed has created a corresponding template.

A deployed workflow appears in the list of template workflows. A workflow can be re-opened to make modifications 
to a template if needed.
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Step 13.	 Locate the template that was created by the Template Workflow.

 a.	 Navigate to the Configuration > Templates > Device Templates dashboard, then locate the new template that was 
created by the workflow.

 b.	 Open the new template.

Click the new template to open the template in Template View.

The main view changes to Template View, and the template configuration is displayed.

 c.	 Navigate to the Stateful Firewall services

In the template, click on the Services tab on the left side menu. This will display the services configuration 
hierarchy.

 d.	 Expand the Stateful Firewall service menu

In the Services menu on the left side, locate and click on the Stateful Firewall menu entry to expand the list of 
stateful firewall services available in the template.
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Step 14.	 Create a new Device Group
Next you will create a device group that uses the new template.

 a.	 Switch to Director View

Click on the Director View button at the top of the window to exit the Template View.

 b.	 Open the Device Groups menu

In Director View, navigate to Configuration > Devices > Device Groups. This will display a list of device groups 
that are pre-configured in the system.

 c.	 Add a Device Group

Click on the +Add button to create a new device group.

 d.	 Assign the main template and device group settings

•	 Provide a name for the new device group based on your student: Sxx-DG-New.
•	 Select your student ID (organization name) from the Organizations drop-down menu.
•	 Select the Sxx-Template-New template from the Post Staging Template drop-down menu.

Refer to the image on the following page for an example of the Device Group configuration.
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 e.	 Scroll to the bottom of the device group window. Note that the Sxx-Template-New template is listed as the Main 
template for the device group. The Datastore template is an organization level template that is automatically applied to 
all templates in the organization.

 f.	 Click OK to finish creating the device group.



(C) Versa 2025

Versa Networks Lab Guide:
SD-WAN Configuration and Administration

36

Step 15.	 Assign your branches to the new Device Group

 a.	 Navigate to Workflows > Devices > Devices.

 b.	 Open the SxxB01 device workflow.

 c.	 In the BASIC dashboard, change the Device Group to the Sxx-DG-New device group you just created.

 d.	 Click the Next button until you reach the Review dashboard.

Note: In the Bind Data tab, ensure that the LAN address is present. If the LAN network name in the new template 
is different from the LAN name in the previous template, it will require that you re-add the LAN IP addresses to the 
devices (because the new LAN variable name will be different from the old LAN variable name). If the bind data 
needs to be re-entered, please notify your instructor for guidance.

 e.	 Click the Re-Deploy button in the Review dashboard to reconfigure the device parameters.

 f.	 In the Device Workflows window, open the Sxx_B02 device workflow.

 g.	 Repeat steps b, c, d, and e for the S02 device.
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Step 16.	 Verify the Device Group assignments.

 a.	 Navigate to the Configuration > Devices > Device Groups dashboard.

 b.	 In the Device Groups dashboard, locate the Sxx-DG-New device group. On the right hand side, verify that both of your 
branches are members of the device group.

Step 17.	 Commit the template to the devices

 a.	 Click the Commit Template box in the top right corner of the main dashboard.

 b.	 In the Commit Template to Select Devices dialog, ensure that your organization is listed in the Organization drop-down 
menu.

 c.	 In the Select Devices By box, select Template.

 d.	 In the Template drop-down menu, select the new template that you created (e.g. Sxx-Template-New).

 e.	 Click the Fetch Devices button to query a list of devices that use the selected template. Your two branch devices should 
be displayed.
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 f.	 Check the boxes next to your two devices.

 g.	 Click the Review button.

The review dialog should show that both devices are selected for updates.

 h.	 Click the Commit button.

The commit button will recreate the device configurations using the newly assigned template and copy the 
configurations to the devices.

Step 18.	 Verify the changes.

 a.	 Navigate to the Administration > Appliances dashboard, or click Appliance View from the top of the dashboard.

 b.	 Click on your B01 device to open the device.

 c.	 Open the Monitor dashboard

 d.	 In the B01 Appliance View, open the Monitor dashboard. Open the System sub-tab.

You can view the template association in the System dashboard. You may have to scroll down on the device Monitor 
dashboard to view the Associate Templates block.
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Step 19.	 Verify the device services configuration

 a.	 Navigate to Configuration > Services

While in Appliance view, click on the Configuration tab to view the device configuration. Navigate to the Services 
tab and expand the Stateful Firewall item. You can see that the Stateful Firewall services are configurable on the 
device. If you click on the Appliance drop down menu and select the B02 branch, you will see that the services are 
synchronized on both devices, as they are in the same device group.

Step 20.	 Clone the new Template Workflow

 a.	 Open the Configuration > Workflows > Template > Templates dashboard

Workflows can be cloned, which allows you to create a copy of an existing workflow with a new name. This allows 
you to create a new workflow and template, with a different name, that inherits the same properties as the original. 
You can then make adjustments to the properties that you want to change without the requirement of rebuilding the 
workflow from the beginning.
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 b.	 Clone the Sxx-Template-New workflow

Mouse over the Template-Sxx-Template workflow. Once highlighted, a menu appears on the right side of the row. 
Click on the Clone button to create a clone of the workflow. A new workflow process appears.

 c.	 Rename the cloned Workflow Template

The new workflow name includes the word Copy_of_ followed by the original workflow name. Rename the new 
workflow to Sxx-Template-New-NGFW, where xx is your student number (e.g. S01-Template-New-NGFW).

 d.	 Change the enabled firewall service

Scroll down to the Organizations box and change the Firewall Service to Nextgen Firewall.
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 e.	 View the port configuration

Click the Next button to continue to the Device Port Configuration dialog. Note that the port information from the 
original workflow remains, which means you do not have to reconfigure the ports.

 f.	 Deploy the template workflow.

Click the Next button until you reach the Review dashboard. In the Review dashboard, click the Re-Deploy button to 
deploy the new workflow and create the new template.
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 g.	 Verify the new template creation

To verify that the workflow clone created a new template, navigate to the Configuration > Templates > Device 
Templates dashboard. You should see your new template in the template table.

 h.	 Open the new template

Click on the Sxx-Template-New-NGFW template to open the template.

 i.	 Verify the Next Gen Firewall security settings

Navigate to the Configuration > Services dashboard. The Next Gen Firewall services are configurable in the new 
template.
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 j.	 Return to Director View

Click on the Director View button at the top of the dashboard to return to Director View

To use the new template, it has to be assigned to devices in a device group. You will change the new device group 
you just created so that the template used by the device group is the new NGFW based template.

 k.	 Navigate to the Device Group dashboard

Navigate to the Configuration > Devices > Device Group dashboard.

 l.	 Open the Sxx-DG-New device group

 m.	 Assign the NGFW template to the device group.

Change the Post Staging Template to the new template that you just created with the Clone tool.
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 n.	 Click OK to complete the change.

You just changed the post staging template associated with the device group that contains your two devices. It is 
now time to apply that configuration change.

 o.	 Click the Commit Template button

In the Commit Template dialog, ensure that your Studentxx organization is selected. You can search for devices by 
device group or by template. In this exercise we will search for devices that are associated with the device group.

 p.	 Fetch devices based on device group

Select Device Group in the Select Devices By drop down menu. In the drop down menu next to it, select the 
Sxx-DG-New device group (the device group your devices are members of), then click the Fetch Devices button. 
Your devices should appear in the list.

 q.	 Commit the changes

Check the boxes next to your devices, then click the Review button at the bottom of the window.

Click the Commit button at the bottom of the review window to create new configurations for the devices and apply 
the configurations to the devices.
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Step 21.	 Verify the configuration changes on the appliances

 a.	 Navigate to the Administration > Appliances dashboard and open your B01 appliance.

To verify that the configuration changes have been applied, navigate to Administration > Appliances and select the 
SxxB01 device from the appliance list. Alternatively, click on the Appliance View and select the SxxB01 device 
from the list. This will open the Appliance View of the device.

 b.	 Verify the Next Gen Firewall services are available

Open the Services menu on the left side menu. Verify that the Next Gen Firewall services now appear in the services 
list of the device configuration.
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Step 22.	 Clone a Template
In the next steps you will clone a template from the Configuration > Templates database. This will create a copy of an existing 
template and it will create a basic Template Workflow associated with the cloned template.

 a.	 In Director View, navigate to Configuration > Templates > Device Templates.

 b.	 From the device templates, locate and click on the box next to the Sxx-Template-New-NGFW template that you 
previously created. After you check the box next to the template, the actions menu in the top-right of the panel will 
activate.

 c.	 Locate and click on the Clone button to create a copy of the template.

After you click the Clone button, the Clone Template dialog will appear. For the purposes of this exercise, you can 
leave the auto-generated name of the template.

 d.	 Click OK to create the clone (copy) of the template.
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When you create a copy or clone of a template, a corresponding template workflow is created in the Workflows 
dashboard.

 e.	 Verify the workflow for the cloned template

Navigate to Workflows > Template > Templates. Verify that a workflow has been created with the same name as the 
cloned template.

It is important to remember the following when cloning workflows and templates. If you clone a workflow, the 
properties of the workflow are copied, and the template that is created contains those properties. If you clone 
a template, only the properties of the template that have corresponding workflow properties are copied to the 
workflow. For example, if you created a template using a workflow and you have modified the template by adding 
properties such as class of service rules, security rules, or traffic steering rules, the customized properties will be 
copied to the template, but the workflow will only contain the basic properties that are available to the workflow, 
so care must be taken when deploying the workflow (use the Deploy option instead of Clean & Recreate when 
deploying the workflow in the future to prevent erasing custom template properties – unless you intend to erase any 
customizations in the template and to start with a clean, new template).
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DEVICE WORKFLOWS
In the next exercises you will create a new device with a device workflow. However, you will not go through the process of 
onboarding an appliance that references this device.

In this exercise you will:

•	 Create a device by using a Device Workflow;
•	 Create a workflow spreadsheet with the workflow Export process;
•	 Update the exported spreadsheet with information for a new device; and
•	 Import device workflows from a spreadsheet.

Step 1.	 Open the Device Workflows dashboard

 a.	 In Versa Director navigate to the Workflows > Devices > Devices dashboard.

 b.	 Create a new Device Workflow

Click the + Add button to create a new device workflow.
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 c.	 Configure the Basic properties

For each of the following, the xx value represents your assigned student number (e.g. Studentxx would be 
Student01, Student02, etc.)

•	 Name: Studentxx-New-Branch
•	 Organization: Studentxx
•	 Serial Number: SN-SxxNew
•	 Device Group: DG-Sxx-NGFW

 d.	 Configure the Location

•	 Click the Next button to continue to the Location dialog. Enter the City as San Jose, the state as CA, and the 
country as USA

•	 Click the Generate to get the coordinates of the address
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 e.	 Navigate to the Device Service Template window.

Click Next to navigate to the Device Service Template window. If you have configured service templates you can 
apply them to a group of devices through the device group, or you can apply service templates directly to a device in 
the device workflow.

For our example we will not add any service templates to the device directly.

 f.	 Click the Next button to move to the Bind Data window.

You may notice a brief delay when the Bind Data window is opened. This is because Versa Director scans the 
templates associated with this device for variables and automatically generates system-assigned values to those 
variables. The user-defined variables, such as IP addresses and gateway addresses, are presented in forms for user 
input.

Bind data variables are sorted according to their type. In our example there are interface variables and virtual router 
variables, as shown on the left side of the window.

Interfaces Bind Data
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Virtual Router bind data (default gateway routes, etc.)

 g.	 Enter the following values (also shown in the diagram). Because we will not be onboarding the device, all students can 
enter the same information without causing any IP conflicts.

•	 INET_IPv4_staticaddress: 10.27.11.201/24
•	 MPLS_IPv4_staticaddress: 10.27.12.201/24
•	 Student_LAN_IPv4_staticaddress: 10.27.201.10/24
•	 INET-Transport-VR_IPv4_vrHopAddress: 10.27.11.1
•	 MPLS-Transport-VR_IPv4_vrHopAddress: 10.27.12.1

 h.	 Click Next to go to the Review dashboard.

In the review window you can view the properties that have been defined for this device. You can scroll down the 
window to see more properties, including the bind data values you provided.
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The Save button saves the workflow in its current state, but does not create the device object in the hardware inventory. To create the 
device in the hardware inventory, click the Deploy button.

 i.	 Click the Deploy button to deploy the workflow and create the device in the hardware inventory.

You can see the workflow status in the Devices workflow table, as shown below.

Verify the new device in the Hardware Inventory

 j.	 Navigate to Administration > Inventory > Hardware to view the hardware inventory.

In the hardware inventory you should see your new device. There is not a Hardware Serial Number value attached, 
as the new device has not been associated with a physical appliance.

At this point the device is ready for onboarding. With the onboarding process (not covered in this lab), the appliance 
is connected to the WAN and the onboarding process starts with either the URL based onboarding, by running the 
onboarding script, or through the global ZTP process. When the appliance contacts the controller, it will provide the 
hardware serial number to the headend. The hardware serial number will then be listed in the hardware table (as it 
will be associated with the device), and the appliance will be placed in the Appliances table.

STOP! Notify your instructor that you have completed this lab.STOP
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TOPOLOGIES
The Versa Networks lab environment consists of a fixed, pre-configured topology that will allow you to explore, configure, and 
manage Versa Networks CPEs by using Versa Director, the central management and orchestration platform for a Versa Secure SD-
WAN solution. After completing this lab, you will be able to:

•	 Analyze the configuration components of full mesh and hub-and-spoke topologies
•	 Configure and analyze the following topologies:

•	 Spoke-to-Hub-Only
•	 Spoke-to-Spoke-via-Hub
•	 Spoke-to-Spoke-Direct

In this lab you will be assigned two CPE devices (Branch devices) for configuration and monitoring. The branch devices are named 
after the student ID that you have been assigned.

The lab environment is accessed through Amazon Workspaces. Your student ID and workspace will be assigned by the instructor.

The remote desktop connection opens a remote workstation, where you will use various tools to navigate and configure the lab 
environment. The main tool you will use in this lab is Versa Director. Versa Director can be accessed by opening the Google Chrome 
browser on the Remote Desktop. The IP address of the Versa Director (from the remote workstation) is 10.27.1.10. Once you begin the 
lab, you may want to create a bookmark to Versa Director in the web browser on the remote desktop.

During certain lab parts, the lab guide will present sample output from the GUI or the CLI. The sample outputs are SAMPLES and 
represent the information as it appeared during the lab guide creation. Your output may vary in some ways (some devices may or may 
not be present, some routes may or may not be the same, etc.) Do not be alarmed if your results vary slightly from the results shown in 
the lab guide. The important thing is that the lab functions in the desired manner.

This lab guide will step you through some common tasks that are performed on Versa Director. After an introductory set of exercises, 
you will be asked to perform some basic tasks that will allow you to become more familiar with the environment.

The goal of this and all lab exercises is to help you gain additional skills and knowledge. Because of this, the lab guide contains 
additional instruction to supplement the student guides.

Now that we’ve discussed what is expected, let’s get started!
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Step 1.	 Create a Spoke Group
In this exercise you will create 2 spoke groups. As we move through the lab you will change the type of spoke group in order to 
change the behavior of the routing policies and traffic forwarding. The spoke groups that you will create are based on the student ID 
that you were assigned.

 a.	 Log into Versa Director

 b.	 In Versa Director, navigate to Workflows > Template > Spoke Groups.

 c.	 In the Spoke Groups workflow, create a spoke group with the name Sxx-SG01, where xx is your student number.

 d.	 Set the LAN-VR spoke group type to Spoke to Hub Only.

 e.	 In the Hub dropdown you should see SPHUB-NEW. This is the shared hub for all tenants.

 f.	 Set the hub priority to 1.
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 g.	 Click Create to create the spoke group.

 h.	 Repeat steps c through g process to create a spoke group named Sxx-SG02 with the same properties.

Before you add the devices to a hub and spoke topology, we’ll analyze the policies that exist in the default full-mesh topology.

End result
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Step 2.	 Examine BGP Policies

 a.	 Open your SxxB01 Branch Device to view the configuration

Click the Appliance View at the top of the dashbvoard, and then click on the SxxB01 branch device, where xx is the 
student ID that has been assigned to you.

 b.	 Open the Control Router

In the Appliance view, navigate to Configuration > Networking > Virtual Routers and locate the Studentxx-Control-
VR virtual router. Click on the Control router to open its configuration.

The control router runs the primary BGP instance for the Layer 3 VPN (SD-WAN) connections.

 c.	 Open the BGP Routing Instance in the Control Router

BGP advertises and receives routes to and from the controller. Navigate to the BGP tab of the control router, then 
click on the instance ID of the BGP process to open the BGP configuration.

 d.	 View the BGP Peer and Peer Group Policies

The BGP peer and BGP peer group policies are located in the Peer/Group policies. There are 2 default policies 
created. Navigate to the Peer/Group Policy tab. In a full mesh topology, the default Import-From-SDWAN-Policy 
allows all routes received from the controller.
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 e.	 Click Cancel to exit the Policy window.

 f.	 Click Cancel to exit out of the BGP window.

 g.	 Click Cancel to exit out of the Control VR configuration window.

 h.	 Open the Student-LAN-VR

From the Virtual Routers table, locate and click on the Student-LAN-VR to open the LAN facing virtual routing 
instance. The LAN virtual router contains the LAN facing port and the local LAN routes. It also has policies that add 
routesfrom the LAN routing tables to the BGP updates sent by theControl router.

The Redistribution Policies search for routes in the LAN routing table that should be added to the BGP updates. 

 i.	 Click on the Redistribution Policies tab in the LAN VR.

The default redistribution policy rejects the IP addresses that are used for local processes on the device, so that they 
are not advertised to remote devices. The term T2-DIRECT matches the Direct type of route, or the local LAN link, 
and adds it to the update. The T4-BGP policy adds any LAN VR BGP routes to the Control router BGP updates and 
allows them to migrate from one routing domain to another. You can open the policy to view more details.

 j.	 Open and Examine the T2-DIRECT policy term.
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 k.	 Click on the Redistribute To tab in the Redistriubtion Policies window.

The Redistribute To tab identifies from where the routes come, and to where the routes should be moved according 
to the terms in the rules.

With this configuration, the routes move from the LAN VR unicast table to the main BGP process routing updates 
according to the rules in the defined policy name.

 l.	 Click Cancel until you have exited the LAN-VR configuration and exit without making any changes.
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Step 3.	 Apply Spoke Groups
Next you will modify the main NGFW template so that it is a spoke template associated with the Sxx-SG1 spoke group.

 a.	 Click the Director View button at the top of the window.

 b.	 In Director View navigate to Workflows > Template > Templates.

 c.	 Locate the Sxx_Template-NGFW workflow, where Sxx is the student number assigned to you.

 d.	 In the Template-NGFW workflow, select Spoke in the Device Type. Note that when you select Spoke as the device 
type, a new field is created in the Organizations section to select the spoke group.

 e.	 Select the Sxx-S01 spoke group.

 f.	 Click the Next button until you arrive at the Review page.
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 g.	 In the Review page, click Clean & Recreate to rebuild the template with the new spoke group assignment.

 h.	 Click Confirm when prompted.

To apply the changes, you will need to commit the template to rebuild the device configurations with the new 
template settings and copy the configurations to the devices.

 i.	 Click the Commit button

 j.	 In the Commit Template to Select Devices page, select your organization in the Organization menu, select Template 
in the Select Devices By menu. Select the Sxx_Template-NGFW as the template, then click the Fetch Devices button. 
Your devices should be displayed in the table.

 k.	 Check the boxes next to all of the devices.

 l.	 Click the Review button.

 m.	 In the Review page, click Commit to apply the changes.
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Step 4.	 Identify changes made by the Spoke Group configuration
Next we will identify and verify the changes that were made when the topology type was changed.

 a.	 Click on Appliance View, then locate your SxxB01 branch in the table.

 b.	 Click on the branch name to open the branch in Appliance View mode.

 c.	 In Appliance view of your SxxB01 device, navigate to Configuration > Networking > Virtual Routers.

 d.	 Locate the Studentxx-Control-VR and click on the control router to open its configuration.

 e.	 Navigate to BGP and click on the BGP instance to open the BGP configuration.
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 f.	 Click on the Peer/Group Policy tab.

Note the addition of multiple terms to the policies.

 g.	 Open the Import-From-Hubs-Policy

 h.	 In the Import-From-Hubs-Policy, click on the Reject-VersaPvt-Spokes term to open the term.

Note that the match conditions search for specific community values. These values are values associated with a 
specific spoke group. Depending on your environment the values you see may be different from the example. Take a 
note of the values in the Community field. The same communities are matched in the Reject-Spokes-Student-LAN-
VR term.
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 i.	 Click Cancel to close the term without making changes.

 j.	 Locate and click on the Hub-Priority1-Student-LAN-VR term.

This term matches based on an Extended Community value that is associated with the hub device.

 k.	 Click on the Action tab of the term.

In the action tab, the route is set to Accept, and the Local Preference of 108 is assigned. This is the value assigned to 
the routes received from the hub to make them more preferred. In a topology with multiple hubs, each hub will have 
a different Local Preference assigned to ensure that routes from the highest available hub are preferred in the routing 
table.

 l.	 Click Cancel until you exit the virtual router configuration and return to the main branch configuration page.
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 m.	 In the main configuration page, under Virtual Routers, locate and click on the Student-LAN-VR routing instance.

In the Student-LAN-VR routing instance, open the Redistribution Policies tab.

The terms in the redistribution policy appear to be the same, but upon closer inspection of the terms we can see that 
a Set Community property has been added.

 n.	 Click on the Default-Policy-To-BGP policy to see an overview of the change.

Note that one of the community values that is added to the redistributed routes matches the BGP community 
value that we saw in the BGP import policy (in this case, 8000:2). This allows remote sites to identify the source 
of these routes, what spoke group the routes are part of, and allows the BGP policies on other devices to filter the 
advertisements.

 o.	 Click the Cancel button until you have exited the virtual router configuration. When asked to confirm, click Yes.



(C) Versa 2025 (C) Versa 2025

Versa Networks Lab Guide:
SD-WAN Configuration and Administration

65

Step 5.	 Verify the Routing Changes
Next we will verify the routing changes that were made in the topology by examining the routing tables of the two branch devices.

 a.	 Navigate to the Monitor tab in Appliance view.

In the Monitor dashboard, ensure that the SxxB01 branch is selected, where Sxx is the student ID assigned to you.

 b.	 Navigate to the Networking > Routes dashboard

 c.	 Select the Student_LAN-VR routing table from the dropdown to view the routes in that virtual router.

There are 2 main routes you will focus on in this lab exercise. The LAN route for branch B01 and the LAN route for 
branch B02. The routes for those branches will depend on your organization (Student) number.

Because this is a spoke-to-hub only topology, the routes to the other spokes are not present in the routing table. 
However, the route to the hub LAN is present (10.27.130.0/24). If you choose to do so, you can open the SxxB02 
device and view the LAN routing table to see the same behavior on branch B02.

Step 6.	 Change the Spoke Group to Spoke to Spoke via Hub.

Next we will change the spoke group type to Spoke to Spoke via Hub and examine the effects.

 a.	 Navigate to Director View > Workflows > Template > Spoke Groups to open the Spoke Group configuration workflows 
dashboard.

 b.	 Locate and click on spoke group Sxx-SG1 to open Spoke Group 1.
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 c.	 Change the Spoke Group Type to Spoke to Spoke Via Hub. Leave all other parameters the same.

 d.	 Click Recreate to rebuild the spoke group settings.

Because the spoke group is part of the template settings, we need to rebuild the template using the template workflow.

 e.	 Navigate to Workflows > Template > Templates. Locate the Sxx_Template-NGFW workflow.

 f.	 Open the Sxx_Template-NGFW workflow

 g.	 Click the Next button until you reach the Review page.

 h.	 On the Review page, click Clean & Recreate to rebuild the template with the new spoke group settings.

 i.	 Click Confirm to allow the recreation of the template.
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The template has been updated. Now the changes in the template need to be committed to the devices.

 j.	 Click the Commit Template button.

 k.	 In the Commit Template to Select Devices, select your organization in the Organization drop down. Select the devices 
by Template, and select the Sxx_Template-NGFW template from the template list.

 l.	 Click Fetch Devices. Your branch devices should display in the table.

 m.	 Click the boxes next to your devices, then click Review.

 n.	 In the Review window, click Commit to apply the changes.
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Step 7.	 Verify the policy and routing changes
Next we will verify the policy changes and routing changes.

 a.	 Navigate to Appliance View and select device SxxB01 from the device list.

 b.	 In the SxxB01 dashboard, navigate to Monitor > Networking > Routes.

 c.	 Select the LAN-VR routing instance from the drop down menu.

This will display the routes in the B01 LAN routing table.

Note that the LAN route from branch B02 is now present, but that it has a next hop site of the SPHUB-NEW device 
and NOT the B02 branch device.

 d.	 Click on the Total Appliances tab to view a list of all of the appliances.

 e.	 From the appliances table, click on the B02 branch device.
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 f.	 In the SxxB02 appliance window, navigate to Networking > Routes.

 g.	 Select the LAN-VR virtual router from the drop down menu.

Note that the LAN route from branch B01 has a next hop site of the SPHUB-NEW device, and NOT the B01 device.

Because of this topology type, the branch LANs can communicate, but all traffic is relayed through the hub, and 
branches do not have direct tunnels between them.
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Step 8.	 Configure Spoke to Spoke Direct
In the next exercise you will change your devices to Spoke to Spoke Direct in the spoke group. In the first part you will place both 
devices in the same spoke group and examine the routing tables.

 a.	 From Director View, navigate to Workflows > Template > Spoke Groups.

 b.	 From the Spoke Groups table, click on Sxx-SG1 to open Spoke Group 1.

 c.	 Change the Spoke Group type to Spoke to Spoke Direct. Note how the Community dropdown is activated with the 
Spoke to Spoke Direct spoke group type.

 d.	 Click the +Community Options link below the Community drop down menu. The Community dialog opens.

 e.	 In the Community dialog, click the + button to add a community. Name the Community Group-1 and assign a 
community ID of 1.

 f.	 Click the + button again and add a second community called Group-2. Assign the community ID of 2.

Your communities should look like the example below.
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 g.	 Assign community Group-1 to the spoke group.

 h.	 Click the Recreate button to apply the changes to the spoke group.

 i.	 Open Spoke Group 2 (Sxx-SG2)

 j.	 Change Spoke Group 2 to Spoke to Spoke Direct.

 k.	 Assign community Group-2 to spoke group 2.

 l.	 Click Recreate to apply the changes to spoke group 2.
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Next you will open the Sxx_Template-NGFW template workflow and re-create the template to ensure that the new spoke group 
settings are applied.

 m.	 Navigate to Workflows > Template > Templates.

 n.	 In the Template workflow table, locate and click on the Sxx_Template-NGFW workflow to open the workflow.

 

The proper settings are already in place for the workflow. However, because the properties of the spoke group 
assigned to the template have changed, we will re-create the template again to ensure that the spoke group settings 
are re-copied into the template.

 o.	 Click the Next button until you reach the review page.

 p.	 On the Review page, click the Clean & Recreate button to rebuild the template.
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Step 9.	 Clone the Sxx_Template-NGFW workflow.
Next you will create a clone of the Sxx_Template-NGFW. The cloned workflow will have the same properties as the original 
workflow.

 a.	 Navigate to Director View > Workflows > Template > Templates.

 b.	 In the Template Workflow table, check the box next to the Sxx-Template-NGFW.

Note the Actions buttons that appear on the right side of the table.

 c.	 Click the Clone button to create a clone of the workflow.

 d.	 Rename the cloned workflow to Sxx_Template-NGFW-SG2, where Sxx refers to your assigned student number.

 e.	 In the Organizations settings, change the spoke group to Sxx-SG2.

 f.	 Click the Next button until you reach the Review page.

 g.	 In the Review page, click Deploy to save the workflow and create the new template.

You should now have two templates for spoke groups. The only difference between the templates is the spoke group 
to which they are assigned.
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Next you will re-assign branch B02 to a new device group. The new device group will reference the SG2 template.

 h.	 Navigate to Workflows > Devices > Devices.

 i.	 From the Devices workflow table, click on branch SxxB02 to modify the B02 device.

 j.	 In the Basic page, add a new device group.
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 k.	 Name the new device group Sxx-DG-SG2, where Sxx is the student number you have been assigned.

 l.	 Select the Sxx_Template-NGFW-SG2 template as the main device template.

 m.	 Click the OK button to finish creating the device group.

This will take you back to the device workflow and set the new device group as the assigned device group.

 n.	 Click the Next buttons until you reach the Review page.

 o.	 On the Review page, click the Re-Deploy button to update the device properties.



(C) Versa 2025

Versa Networks Lab Guide:
SD-WAN Configuration and Administration

76

Commit the Sxx_Template-NGFW-SG2 template

 p.	 Click the Commit Template button.

 q.	 In the Commit Template to Select Devices page:

•	 Select your organization in the Organization drop down
•	 Choose Select Devices By: Template
•	 Choose template Sxx_Template-NGFW-SG2
•	 Click the Fetch Devices button

Your B02 device should be listed.

 r.	 Check the box next to your B02 device and click Review.

 s.	 On the Review Page, click the Commit button to reprogram the device with the new settings.
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Step 10.	 Reveiw the Spoke to Spoke Direct Results
In the next exercise you will review the routing results of placing 2 devices in different spoke groups with Spoke to Spoke Direct.

 a.	 Navigate to Appliance View and select your B01 device from the device list.

 b.	 In the B01 branch device, navigate to Configuration > Networking > Virtual Routers > Student-LAN-VR.

 c.	 In the LAN-VR virtual router, click the Redistribution Policies tab

 d.	 Click on the Default-Policy-To-BGP policy.
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Identify the extra community value added to the BGP and Direct routes. This is the community value that you set in 
the spoke groups.

Note: To avoid community value overlaps in a multi-tenant system, Versa Director only asks for the 2nd part of the 
community value in the spoke group. The first part (in this case the 8020: prefix) is assigned by Versa Director to 
ensure that your spoke group communities remain unique in the system.

 e.	 Click the Cancel button until you have exited the virtual router configuration.

 f.	 Click Yes to the cancel prompt when prompted.
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 g.	 Switch to the B02 branch device by selecting the B02 device from the Appliance drop down menu.

 h.	 Open the LAN virtual router on the B02 device.

 i.	 In the LAN virtual router, open the Redistribution Policies tab

 j.	 Click on the Default-Policy-To-BGP policy to view the communities assigned on branch B02. Branch B02 should have 
the community associated with spoke group 2.

 k.	 Click the Cancel button until you exit the virtual router configuration.
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 l.	 Navigate to Monitor > Total Appliances.

 m.	 In the appliance list, select the B01 branch device. The B02 device should already be opened in a tab.

 n.	 In the SxxB01 device Monitor dashboard, navigate to Networking > Routes.

 o.	 Select the LAN-VR virtual router from the drop down menu.

Note that the LAN routes associated with branch B02 list the SPHUB-NEW as the next-hop device, as the B02 
device is in a different spoke group.



(C) Versa 2025 (C) Versa 2025

Versa Networks Lab Guide:
SD-WAN Configuration and Administration

81

Step 11.	 Spoke to Spoke Direct - Devices in the same Spoke Group
Next you will place both devices in the same spoke group. Because both devices are in the same spoke group, and the topology is set 
to Spoke to Spoke Direct, the devices should form direct tunnels to each other (full mesh between devices in the same group).

 a.	 Navigate to Director View > Workflows > Devices > Devices and locate your B02 branch device in the device list.

 b.	  Click on the B02 device to open its properties.

 c.	 Assign branch B02 to the DG-Sxx-NGFW device group.

 d.	 Click the Next button until you reach the Review page.

 e.	 In the Review page, click the Re-Deploy button to assign the new properties to the B02 device.
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Next you will commit the template to the devices.

 f.	 Click Commit Template.

 g.	 From the Commit Template to Select Devices dialog:

•	 Set the Organization to your organization value
•	 Select Devices By: Template
•	 Choose the Sxx_Template-NGFW template
•	 Click Fetch Devices
•	 Select the SxxB02 device from the list (or select both devices)
•	 Click the Review button

 h.	 On the Review page, click the Commit button to apply the changes.

 i.	 Navigate to Monitor > Devices > Total Appliances.

 j.	 Click on your B02 branch device.

 k.	 Navigate to Networking > Routes.

 l.	 Select the LAN-VR routing instance from the drop-down menu.

Note that there are 2 routes to the branch B01 LAN (one direct route to the B01 device, and another route to the 
SPHUB-NEW device). The + symbol in front of one of the routes indicates that it is the active route. The other route 
is a backup route.
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Step 12.	 Reset the lab environment
In the next steps you will reset the lab environment, which includes resetting the Sxx_Template-NGFW workflow back to the Full 
Mesh topology type. You will then commit the template to your devices to configure them in a full mesh topology.

 a.	 Navigate to Workflows > Template > Templates.

 b.	 Locate the Sxx_Template-NGFW template workflow, then click on the workflow to open it.

 c.	 In the Sxx_Template-NGFW workflow, change the Device Type to Full Mesh.

 d.	 Click the Next button until you reach the Review page.

 e.	 In the Review page, click on the Clean & Recreate button to save the workflow and rebuild the template.

 f.	 Click Confirm when prompted.
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Next you will remove the Sxx-DG-SG2 device group.

 g.	 Navigate to Configuration > Devices > Device Groups.

 h.	 Locate the Sxx-DG-SG2 spoke group and check the box next to the spoke group to select it.

 i.	 Click on the Delete button in the top right to delete the device group.

IMPORTANT: Ensure that you are deleting the device group that you added for this lab exercise!

Next you will remove the Sxx_Template-NGFW-SG2 template workflow, which will also remove the associated template.

 j.	 Navigate to Workflows > Template > Templates.

 k.	 Locate the Sxx_Template-NGFW-SG2 workflow, where Sxx refers to the student ID assigned to you.

 l.	 Check the box next to the template to select it, and then click the Delete button in the top right corner.

 m.	 Confirm the deletion when prompted.
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Finally, you will commit the Sxx_Template-NGFW template to your devices to rebuild and apply their configurations.

 n.	 Click the Commit Template button.

 o.	 In the Commit Template to Select Devices dashboard:

•	 Select your organization from the Organization drop down;
•	 Select Devices By: Template;
•	 Select the Sxx_Template-NGFW template from the template drop down;
•	 Click Fetch Devices – your two branch devices should be displayed;
•	 Check the boxes next to the devices to select both branch devices

 p.	 Click the Review button.

 q.	 In the Review page, click Commit.

STOP! Notify your instructor that you have completed this lab.STOP
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DIRECT INTERNET ACCESS
The Versa Networks lab environment consists of a fixed, pre-configured topology that will allow you to explore, configure, and 
manage Versa Networks CPEs by using Versa Director, the central management and orchestration platform for a Versa Secure SD-
WAN solution. After completing this lab, you will be able to:

•	 Configure Direct Internet Access, or DIA for Internet Breakout on a branch device
•	 Verify the routing tables and default routes for DIA configured devices.

In this lab you will be assigned two CPE devices (Branch devices) for configuration and monitoring. The branch devices are named 
after the student ID that you have been assigned.

The lab environment is accessed through Amazon Workspaces. Your student ID and workspace will be assigned by the instructor.

The remote desktop connection opens a remote workstation, where you will use various tools to navigate and configure the lab 
environment. The main tool you will use in this lab is Versa Director. Versa Director can be accessed by opening the Google Chrome 
browser on the Remote Desktop. The IP address of the Versa Director (from the remote workstation) is 10.27.1.10. Once you begin the 
lab, you may want to create a bookmark to Versa Director in the web browser on the remote desktop.

During certain lab parts, the lab guide will present sample output from the GUI or the CLI. The sample outputs are SAMPLES and 
represent the information as it appeared during the lab guide creation. Your output may vary in some ways (some devices may or may 
not be present, some routes may or may not be the same, etc.) Do not be alarmed if your results vary slightly from the results shown in 
the lab guide. The important thing is that the lab functions in the desired manner.

This lab guide will step you through some common tasks that are performed on Versa Director. After an introductory set of exercises, 
you will be asked to perform some basic tasks that will allow you to become more familiar with the environment.

The goal of this and all lab exercises is to help you gain additional skills and knowledge. Because of this, the lab guide contains 
additional instruction to supplement the student guides.

Now that we’ve discussed what is expected, let’s get started!
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Direct Internet Access, also referred to as Split Tunnel, allows data sessions from a private network to “break out” of the private 
network at a branch site, so Internet destined traffic does not have to cross a tunnel to reach a public destination. It does this by 
creating a bridge between a customer VRF routing table and the Public Internet facing virtual router. A default route is advertised from 
the public Internet router to the Tenant routing table that directs public-destined traffic to the INET routing table, where the traffic is 
forwarded to the public Internet after having basic Interface NAT applied.

All of the functions of basic DIA are implemented when a DIA tunnel is configured in a template workflow. A template workflow 
performs the following tasks:

•	 Two Tunnel interfaces are created. One is placed in the Tenant routing table, the other is placed in the INET routing table. The 
tunnel interfaces are created as “paired” tunnel interfaces, meaning they are logically connected to each other (like a virtual 
wire). The default security rules allow all traffic from a branch DTVI tunnel (ptvi zone) to be forwarded, so by default changes 
to the security policies are not required for traffic to pass. However, if you wish to restrict or monitor traffic that exits a DIA 
connection, the proper security policies should be put in place.

•	 An EBGP session is created between the two tunnel endpoints, which allows a default route to be advertised from the Internet 
virtual router to the tenant VRF routing table.

•	 A CGNAT policy is created which performs Interface NAT on all traffic that leaves the INET interface, so that traffic that is 
directed to the INET virtual router has a translated address when it leaves the device.
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In this lab exercise you will examine the routing tables that are present on the B01 device. You will modify the NGFW template 
associated with your organization to remove the existing DIA configuration. You will deploy the workflow, which will update the 
device template. You will commit the modified device template to your branch devices. You will examine the changes in the routing 
and interfaces. You will re-enable the DIA tunnel in the template workflow and commit the workflow to re-add the DIA functions to 
the device template. You will commit the updated template to your branch devices.

Step 1.	 Open a remote desktop session to the testing client
Begin the lab by connecting to the remote desktop in AWS. You will use two main applications: Google Chrome (to connect to Versa 
Director) and Remmina.

 a.	 In the remote desktop, open the Remmina application.

In the Remmina application you will use the Linux RDP connection to connect to the testing client and generate web 
sessions to the Internet. The password for the RDP session is versa123.

 b.	 In the Remmina application, open the Linux RDP connection.

If you see a Connection Log window appear, click the OK  
button to continue. Enter the password versa123 when 
Prompted.
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 c.	 In the testing client, open the Chromium browser.

Note that depending on your environment, it may take up to 30 seconds for the remote browser to start properly.

Note the bookmarks in the bookmark bar.

 d.	 Click on two or more bookmarks to open pages to those destinations. It does not matter which you choose. You should 
be able to open the sites.

 e.	 Minimize the Remmina application window to return to the remote desktop.

 f.	 On the main remote desktop (not the Linux testing client), open the Google Chrome browser.

 g.	 In the Google Chrome browser, locate the bookmark to the Versa Director.

 h.	 Click the bookmark to open the Login page for Versa Director, then login using your Versa Director student name and 
password.

 i.	 In Versa Director, navigate to Administration > Appliances and click on your B01 device to open the Appliance context 
where you can examine statistics and configuration of the device.



(C) Versa 2025

Versa Networks Lab Guide:
SD-WAN Configuration and Administration

90

 j.	 Navigate to Monitor > Devices > SxxB01 > Networking > Routes.

 k.	 Select the student LAN-VR from the dropdown table to view the routes in your LAN VR.

You should see 2 default routes. One route is associated with the TVI tunnel interface, and the other route is 
associated with the hub. The route associated with the tunnel interface should be the active route (as indicated by the 
+ symbol next to the route). This is because the route received over the tunnel interface is preferred over the route 
received from the hub.

 l.	 Select the INET-Transport-VR routing table from the drop-down.

The INET-Transport-VR routing table should have a default route towards the public IP address of the service 
provider (in this case it is a private address 10.27.11.1).
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 m.	 Navigate to Configuration > Networking > Interfaces > Tunnel to view the pre-configured tunnel interfaces.

Note the interfaces that are of type “paired” and their descriptions.

 n.	 Navigate to Configuration > Networking > Virtual Routers and identify where the tunnel interfaces are placed.

You should see one of the tunnel interfaces in the INET-Transport-VR and one in your student LAN-VR routing 
table.

This allows the two routing tables (in different virtual routers) to communicate.
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 o.	 Navigate to Services > CGNAT > Rules to view the CGNAT rules information. Note that you should have multiple hits 
on the DIA-Rule CGNAT rule.

 p.	 Navigate to the Services > NGFW > Sessions dashboard and locate one of the sessions. Note that you may have to 
scroll to the right on the NGFW tab to locate the Sessions tab.

 q.	 Click on the Session Count number to display the session list:

Scroll through the session list until you locate a session 
Associated with the browser pages that you opened. If you do 
not see a session associated with the pages you opened (normally 
due to session timeout), you can return to the RDP client and 
click more bookmarks to refresh the session list.

 r.	 After you locate an active session to one of the web pages, click on the > symbol next to the session to expand the 
view. Note that the session is marked with SDWAN: No, as the session does not cross the SD-WAN due to the Internet 
Breakout.
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Step 2.	 Remove the DIA connection

 a.	 Click the Director View button at the top of the page to return to Director View.

 b.	 In Director View, navigate to Workflows > Template > Templates to view the Template Workflows.

 c.	 Locate and click on the Template-Sxx-NGFW workflow to view the workflow configuration.

 d.	 In the NGFW template workflow, click on the TUNNELS button to go to the tunnels tab.

 e.	 In the TUNNELS tab, locate the Split Tunnels section.

Note that there is a split tunnel between the Student LAN-VR and the INET WAN interface, and the Direct Internet 
Access box is checked.

 f.	 Click the Delete icon next to the split tunnel to remove the split tunnel from the workflow.

 g.	 Click the Skip to Review button at the bottom of the page.

 h.	 In the Review page, click the Re-Deploy button to view and apply the changes to the workflow and template. 
DO NOT CLICK THE CLEAN & RECREATE BUTTON!
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You will be presented with a review/compare window that shows the changes that will be applied to the template. 
The information on the left is what exists in the current template, and the information on the right is what will be 
present in the template after the deploy operation. Note that the TVI interfaces will be removed, as will many other 
parts of the configuration.

 i.	 Click the Deploy button to accept the changes and update the template.

You have updated the NGFW device template. The next step is to apply those changes to your devices.

 j.	 Click the Commit Template button in the top right corner of the window.

 k.	 In the Commit Template to Select Devices window:

•	 select your organization from the dropdown menu;
•	 select the NGFW template in the Select Devices By field;
•	 and click Fetch Devices to retrieve a list of devices that are associated with the template. Both of your branch 

devices should appear in the device list.

 l.	 Click the boxes next to the branch devices to select them.

 m.	 Click the Review button at the bottom of the window.
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 n.	 In the Review page, click the Commit button to apply the changes to the devices.

 o.	 After the commit operation completes, navigate to the Director View > Administration > Appliances dashboard.

 p.	 Click on the B01 branch device to open the device in Appliance View.

 q.	 Locate and activate the Remmina application (RDP to the testing client) and click on some of the bookmarks in the 
remote browser to initiate new sessions.
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 r.	 Return to the Versa Director window.

 s.	 In Versa Director Appliance View, navigate to Devices > SxxB01 > Monitor > Services > SDWAN.

 t.	 Click on the Sessions tab. The sessions to the web sites are now listed as SD-WAN sessions because they are routed 
through the Hub site (not DIA).

 u.	 Navigate to the Networking > Routes > Student-LAN-VR dashboard.

There should only be one default route present in the Student LAN VR, and that route lists the SP-HUB as the next 
hop.
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 v.	 Navigate to Configuration > Networking > Virtual Routers and view the virtual router interface assignments. Note that 
the two paired TVI interfaces are no longer present in the configuration.

Step 3.	 Re-add the DIA
Next you will re-add the DIA configuration to the device template by using the Template Workflow.

 a.	 Return to Director View > Workflows > Template > Templates

 b.	 Click on the Template-Sxx-NGFW template workflow to open the workflow.
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 c.	 Navigate to the Tunnels tab.

 d.	 In the Split Tunnels section, select your student LAN-VR in the VRF Names drop-down menu.

 e.	 Select the INET WAN interface.

 f.	 Select the Direct Internet Access check box.

 g.	 Click the blue + button to add the split tunnel to the workflow.

 h.	 Click Skip to Review.

 i.	 Click Re-Deploy (DO NOT CLICK Clean & Recreate!)

A window will display the changes that will be made to the existing template. Note that by adding the split tunnel 
to the workflow, many configuration items are created to provide the split tunnel features, including the addition of 
TVI interfaces, BGP sessions, and routing policies.

 j.	 Click the Deploy button to apply the changes to the template.
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Step 4.	 Apply the changes
You have changed the device template. Now you must commit the changes to the devices to reprogram the branch devices.

 a.	 Click the Commit Template button

 b.	  In the Commit Template to Select Devices dialog, select your organization, the Template-Sxx-NGFW template, and 
then click the Fetch Devices button. Your branch devices should appear in the table.

 c.	 Check the boxes next to your branch devices.

 d.	 Click the Review button.

 e.	 In the Review window, click the Commit button to reprogram the devices.

You have completed this lab. If you choose you can go back to the branch device in Appliance View and verify that the interfaces have 
been re-added to the device, the additional default route has been added to the LAN VR routing table, and that the preferred next-hop 
is the TVI interface, with the Hub device as a backup default route.

STOP! Notify your instructor that you have completed this lab.STOP
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VERSA APPLIANCE MANAGEMENT
The Versa Networks lab environment consists of a fixed, pre-configured topology that will allow you to explore, configure, and 
manage Versa Networks CPEs by using Versa Director, the central management and orchestration platform for a Versa Secure SD-
WAN solution. After completing this lab, you will be able to:

•	 Identify when a device configuration is in sync or out of sync with Versa Director
•	 Import and Export device configurations
•	 Create device snapshots
•	 Restore device snapshots
•	 Manage operations on individual devices
•	 Manage security packages on individual devices
•	 Monitor system resources on an individual device

In this lab you will be assigned two CPE devices (Branch devices) for configuration and monitoring. The branch devices are named 
after the student ID that you have been assigned.

The lab environment is accessed through Amazon Workspaces. Your student ID and workspace will be assigned by the instructor.

The remote desktop connection opens a remote workstation, where you will use various tools to navigate and configure the lab 
environment. The main tool you will use in this lab is Versa Director. Versa Director can be accessed by opening the Google Chrome 
browser on the Remote Desktop. The IP address of the Versa Director (from the remote workstation) is 10.27.1.10. Once you begin the 
lab, you may want to create a bookmark to Versa Director in the web browser on the remote desktop.

During certain lab parts, the lab guide will present sample output from the GUI or the CLI. The sample outputs are SAMPLES and 
represent the information as it appeared during the lab guide creation. Your output may vary in some ways (some devices may or may 
not be present, some routes may or may not be the same, etc.) Do not be alarmed if your results vary slightly from the results shown in 
the lab guide. The important thing is that the lab functions in the desired manner.

This lab guide will step you through some common tasks that are performed on Versa Director. After an introductory set of exercises, 
you will be asked to perform some basic tasks that will allow you to become more familiar with the environment.

The goal of this and all lab exercises is to help you gain additional skills and knowledge. Because of this, the lab guide contains 
additional instruction to supplement the student guides.

Now that we’ve discussed what is expected, let’s get started!
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The first exercise will identify when a device configuration becomes out of sync with the configuration in Versa Director. To do 
this, you will log into the shell of one of your branch devices and enable configuration mode through the CLI. You will then enter 
configuration mode, commit the configuration, and then exit configuration mode. Note that you do not have to make a change to the 
configuration to bring the device out of sync, as the act of enabling CLI configuration mode is sufficient to flag it as out of sync.

Step 1.	 Device Configuration Synchronization

 a.	 From Versa Director, navigate to Appliance View

 b.	 Click on your SxxB01 device to open it in Appliance View.

 c.	 From your SxxB01 device in Appliance View, navigate to the Monitor tab.

 d.	 Click the Shell button on the right side of the dashboard. This will open the shell.

Alternatively you can connect to the shell using the Remmina Remote Desktop Client on the remote desktop.
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 e.	 Log into the shell of the B01 device with the username admin and password versa123.

By default configuration mode is disabled from the shell, as the device should be managed and configured by Versa 
Director.

 f.	 Enable the CLI configuration on the device. From the shell enter the command vsh allow-cli. Enter the admin password 
of versa123 when prompted.

 g.	 After CLI mode has been enabled, type cli to start the command line interface.
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 h.	 From the CLI, enter the command configure (or config) to enter configuration mode.

 i.	 From configuration mode, enter the command commit.

 j.	 Enter the exit command to leave configuration mode.

 k.	 Enter the exit command again to leave the CLI. Enter the exit command once more to log out of the device.

 l.	 After you log out, you may close the Shell In A Box window or Remmina window.

Versa Director checks the status of the device at regular intervals to verify the configuration synchronization status. 
It may take a few minutes for Versa Director to notice the changes. While we wait, let’s visit the Application 
Identification database.
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Step 2.	 Examine the Application Database

 a.	 Navigate to Administration > Security Package to view the application identification library information. You will see 
a version for Application Identification Library, and another version for Security Package Upgrade.

The Application Identification Library can be updated from the Administration page. We will look at the Security 
Package Upgrade option later in the lab exercises.

 b.	 Click on the Edit button in the top right corner of the Application Identification Library to open the Upgrade Protocol 
Bundle dialog.

DO NOT UPGRADE THE APPLIANCE, as this will force a reboot of the device. The purpose of this exercise is 
to view where the upgrade process takes place.

 c.	 Click the Cancel button to exit the dialog.
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Step 3.	 Verify the Security Package (SPACK)
Next you will view where the security package updates can be configured.

 a.	 Navigate to Configuration > Others > System > Security Package Updates.

The current Automatic Security Update Settings are displayed.

If you want the branch devices to automatically install the most current security package updates when they are 
released, you can configure the auto-update settings here.

 b.	 Click the Edit button in the top right of the dialog to open the configuration settings.

Configuration settings allow you to specify the Versa Networks 
URL where the security packages are made available, the routing 
instance (virtual router) that has connectivity to the download URL, 
and other parameters.

Some organizations choose to enable automatic updates. Other 
organizationschoose to manage the updates centrally from Versa 
Director, and to applysecurity package updates manually. This may 
be the case when theadministrator wants to test the functionality of 
a security package updateprior to placing it in production.

Security packages are centrally managed from Versa Director in the 
Administration > Inventory > Software Images library. Download 
of securitypackages is only allowed by the provider organization, 
as it affects storageon the Versa Director platform. For a sub-
organization (as in the labenvironment), packages that have been 
downloaded by the provider accountare visible in the Package 
Downloads window.
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 c.	 Navigate to the Appliance Upgrade tab. 

Note: DO NOT UPGRADE THE APPLIANCE! The following steps will show you the location of the upgrade process and the 
steps invovled. An upgrade is not needed.

 d.	 From the Appliance Upgrade window, check the box or boxes next to the appliance or appliances that you want to 
upgrade.

 e.	 Click the Upgrade Appliances button in the top right.

 f.	 From the Upgrade Appliances Security (S-Pack) Package dialog, choose the type of download, the flavour, and the 
package version.

 g.	 Do NOT perform an update on the devices. Click the Cancel button to exit the upgrade dialog without making any 
changes.
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Enough time should have passed to allow Versa Director to discover the configuration synchronization differences.

Step 4.	 Check the Configuration Sync status

 a.	 Navigate to Administration > Appliances. You should see a red alert in the Config Sync row of branch SxxB01.

To view the reason for the configuration synchronization issue, you can compare the configuration that is applied to the appliance with 
the configuration in the Versa Director database.

 b.	 Check the box next to the SxxB01 branch device, then locate and click on the Compare button.
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A dialog will appear with the differences between the configurations highlighted.

A + symbol indicates that the configuration statement is present on the appliance, but not in Versa Director. A - 
symbol indicates that a configuration statement is present in Versa Director, but is missing on the appliance.

You can see in the example that the allow-cli command added a statement to the configuration.

 c.	 Click the X in the top corner of the dialog to close the window.

To synchronize the configuration you can choose one of two options. You can “Sync Config from Appliance” or you can “Sync Config 
to Appliance”. 

The Sync Config from Appliance option copies the appliance configuration into the Versa Director database and replaces the previous 
version of the configuration in the database. Use this option if you want to keep the changes that are on the appliance.

The Sync Config to Appliance option copies the configuration in the Versa Director database to the appliance and removes the changes 
made locally on the appliance. This is the option that you will perform.
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 d.	 Click the Sync To button to synchronize the configuration and to remove the changes you made from the CLI.

 e.	 Click Yes when asked to confirm.

Once finished, the Config Sync status should change to a green check mark.
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Step 5.	 System Settings
Network Time Protocol is used to synchronize date and time on a device with a centralized clock source. This is important for 
authentication services, as well as logging and event tracking.

The NTP server settings are located in the Configuration > Others > System > Time & Date > Time Settings dashboard.

 a.	 Ensure you are in the SxxB01 Appliance View.

 b.	 In the SxxB01 Appliance View, navigate to Configuration > Others > System > Time & Date > Time Settings.

 c.	 Click on the Edit button in the top right to open the NTP settings.

The NTP servers can be added by IP address or FQDN. The routing instance and source network that have reachability to the NTP 
server are assigned.
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Local login parameters can be configured on the devices. It is recommended to change the default login information (admin/versa123) 
for improved security.

External authentication can be configured with TACACS+ or RADIUS authentication. You can set the appliance user authentication in 
the Configuration > Others > System > Appliance User Management > External AAA dashboard.

 d.	 Navigate to Configuration > Others > System > Appliance User Management > External AAA.

 e.	 Click the Edit button to open the settings dialog.
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The Auth Order determines the order that the system queries authentication databases when a user attempts to log into the device. The 
options are:

•	 local-then-remote: The authentication system will compare the username and password to the local user database first. If the 
username/password does not match a local username and password, the device will query the remote server for username/pass-
word. If the username and password entered by the user does not match either database, login is denied.

•	 Remote-then-local: The authentication system compares the username and password to the remote server first, and only queries 
the local database if the username/password does not match the information in the authentication server.

•	 Remote-only: This option will only use the remote server information for authentication. If the remote authentication server is 
not reachable or offline, then the local database will be used as a failover.

 f.	 Click the Cancel button to exit the dialog without making any changes.
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The System Users is where the local users are created with their corresponding authentication parameters.

 g.	 Navigate to Configuration > Others > System > Appliance User Management > System Users to view the current users. 
Note that these are the default users in the system.

Do not make any changes to the local users.
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The system resources are tracked through the Monitor dashboard in Versa Director. Individual device resources are viewed through 
the Monitor dashboard of Appliance View.

 h.	 In the Appliance View of your SxxB01 device, navigate to Monitor > System.

 i.	 Explore the resource utilization of your branch device, including the software version, hardware configuration, 
templates and device group associated with the device, location, and overall system status.
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Step 6.	 Exporting Configuration Elements
Device templates can be exported to a text format for archival, to copy between Versa Directors, or to import into the system at a later 
time.

 a.	 Navigate to Director View > Configuration > Templates > Device Templates to view the device templates database.

 b.	 In the Device Templates dashboard, check the box next to the Sxx_Template-NGFW template. This will activate the 
tools in the top of the panel.

 c.	 Locate and click on the Export button to export a text copy of the configuration template. It will be saved in the local 
Downloads folder of the remote desktop workstation.

 d.	 Click OK to confirm the export function.

 e.	 After you download the template, open the downloads folder (or click on the downloads button in the web browser) and 
open the template file. Its file extension is .cfg, but you can view the file with the Notepad application or a text editor.



(C) Versa 2025

Versa Networks Lab Guide:
SD-WAN Configuration and Administration

116

Device configurations can be exported in a text format. 

 f.	 Navigate to Configuration > Devices > Devices, or navigate to Administration > Appliances.

 g.	 In either location, locate your SxxB01 device and check the box next to the device to select it. In the Administration 
> Appliances view, you will need to click on the More dropdown in the top right corner to see the Import Config and 
Export Config options. The example below is the view from the Configuration > Devices > Devices dashboard.

 h.	 Click the Export Config menu item.

After export, the configuration file will be saved in the Downloads folder of the remote desktop.

 i.	 Open the Downloads folder on the remote desktop, or click on the Downloads button in the web browser to locate the 
SxxB01.cfg configuration file.

 j.	 Open the file with the Notepad or a text editor application.



(C) Versa 2025 (C) Versa 2025

Versa Networks Lab Guide:
SD-WAN Configuration and Administration

117

Scroll down in the configuration file and locate the vni-0/2 configuration statement. It should have a description of “LAN interface: 
Studentxx_Lan”.

 k.	 Change the address 10.27.1xx.10/24 to 10.27.1xx.11/24, then save the file. The xx values will vary depending on your 
student ID.



(C) Versa 2025

Versa Networks Lab Guide:
SD-WAN Configuration and Administration

118

 l.	 Return to Versa Director. In Versa Director, ensure that your SxxB01 device is selected in the devices list.

 m.	 Locate and click on the Import Configuration button.

 n.	 In the Import dialog, locate the SxxB01.cfg file in the remote desktop Downloads folder.

 o.	 Select the file and click Open to load the configuration into Versa Director.

 p.	 Click the OK button to apply the configuration to the device (imported configuration files are automatically applied/
committed to the devices).
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Next you will verify how the configuration of the SxxB01 device changed when you imported the modified configuration file.

 q.	 In the Devices window, click on the SxxB01 device to open the device in Appliance View.

 r.	 In the Appliance View of the device, navigate to Configuration > Networking > Interfaces to view the IP addresses 
assigned to the interfaces. You should see two IP addresses assigned to interface vni-0/2.

A device configuration action performs a configuration merge with the existing configuration (not a configuration 
replace). The old IP address that ends in .10/24 is still in place, but the modified .11/24 is added to the configuration.

Next you will remove the added IP address from the configuration.

 s.	 Click on interface vni-0/2 to open the interface configuration.

 t.	 Click on the Sub Interfaces tab to view the sub interfaces configuration.



(C) Versa 2025

Versa Networks Lab Guide:
SD-WAN Configuration and Administration

120

 u.	 Click on sub interface 0 and navigate to the IPv4 tab.

 v.	 In the IPv4 tab of the sub interface, check the box next to the 10.27.xxx.11/24 IP address in the Static Address box.

 w.	 Click the Delete button to remove the unwanted IP address.

 x.	 Click OK in the Edit Subinterface dialog, then click OK to exit the interface dialog.

This will update the configuration in the database, and also push the new configuration to the branch device 
automatically.

STOP! Notify your instructor that you have completed this lab.STOP
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STATISTICS AND MONITORING
The Versa Networks lab environment consists of a fixed, pre-configured topology that will allow you to explore, configure, and 
manage Versa Networks CPEs by using Versa Director, the central management and orchestration platform for a Versa Secure SD-
WAN solution. After completing this lab, you will be able to:

•	 Monitor the traffic on individual devices in real time
•	 Monitor the interface and service statistics per-device to view counters and metrics
•	 Monitor the status of Versa Director
•	 Monitor the status of the SD-WAN environment as a whole
•	 Navigate the Versa Analytics platform
•	 Display and interpret historical data in Versa Analytics
•	 View logging information in Versa Analytics
•	 Generate reports using Versa Analytics

In this lab you will be assigned two CPE devices (Branch devices) for configuration and monitoring. The branch devices are named 
after the student ID that you have been assigned.

The lab environment is accessed through Amazon Workspaces. Your student ID and workspace will be assigned by the instructor.

The remote desktop connection opens a remote workstation, where you will use various tools to navigate and configure the lab 
environment. The main tool you will use in this lab is Versa Director. Versa Director can be accessed by opening the Google Chrome 
browser on the Remote Desktop. The IP address of the Versa Director (from the remote workstation) is 10.27.1.10. Once you begin the 
lab, you may want to create a bookmark to Versa Director in the web browser on the remote desktop.

During certain lab parts, the lab guide will present sample output from the GUI or the CLI. The sample outputs are SAMPLES and 
represent the information as it appeared during the lab guide creation. Your output may vary in some ways (some devices may or may 
not be present, some routes may or may not be the same, etc.) Do not be alarmed if your results vary slightly from the results shown in 
the lab guide. The important thing is that the lab functions in the desired manner.

This lab guide will step you through some common tasks that are performed on Versa Director. After an introductory set of exercises, 
you will be asked to perform some basic tasks that will allow you to become more familiar with the environment.

The goal of this and all lab exercises is to help you gain additional skills and knowledge. Because of this, the lab guide contains 
additional instruction to supplement the student guides.

Now that we’ve discussed what is expected, let’s get started!
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Step 1.	 Realtime Statistics

Versa Director provides real-time information about the network environment, as well as traffic, service, and policy statistics. In this 
exercise you will:

•	 Generate traffic from the host connected to the B01 branch; and
•	 View live traffic statistics on the B01 device and the SPHUB-NEW device.

To assist with this lab you will run a script that generates ICMP traffic between the B01 branch and the SPHUB-NEW device. This 
will help to populate the traffic statistics.

 a.	 In Versa Director, navigate to the Appliance View and click on your SxxB01 branch device, where Sxx is the student 
number assigned to you. This will open the B01 Appliance.

 b.	 In the B01 Appliance View, navigate to the Monitor tab.

This will allow you to open a console shell to the device.

 c.	 Locate and open the Remmina Remote Desktop Client on the remote desktop.
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 d.	 Open the SSH session to the Linux Testing Client.

If prompted for a password, enter the username student and password versa123 when prompted.

You are now connected to the Linux testing host.

 e.	 From the Linux testing host shell prompt, issue the command ls to list the files in the local directory.

You should see a file called pinghub.sh.

 f.	 Execute the pinghub.sh script by entering the command ./pinghub.sh. This will initiate a ping of 1500 packets towards 
the hub-connected host.

 g.	 Minimize (do not close) the shell window and return to Versa Director.
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 h.	 Return to the Versa Director Monitor dashboard.

 i.	 In the Versa Director Monitor dashboard click the Live Data box to activate the live traffic tracking.

The Live Data box is in the Summary tab. After a few seconds the chart should begin to populate so that you can 
view the traffic flow.

 j.	 In the Application Traffic window, select Remote Branch SPHUB-NEW to view traffic statistics towards the hub site.

If desired, you can click the Latency, Jitter, and Packet Loss boxes to turn on/off the charts associated with each 
statistic.

Data points will be added to the charts about every 2 seconds.
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 k.	 Navigate to the Monitor > Services > SDWAN dashboard.

 l.	 Click on the Sessions tab. You should see a session count table for sessions that cross the SD-WAN circuits.

 m.	 Click on the number next to the session count to view the individual sessions that are active on the device.

 n.	 Locate the ICMP session and click on the session to view the session details. You can see the transmit and receive 
WAN circuit information.

 o.	 In the drop down menu at the top of the table, change the display from brief to extensive to view the extra information 
about the sessions.
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 p.	 Expand the information displayed by selecting Detail or Extensive from the drop down menu.

 q.	 Navigate to the main Sessions dashboard. This displays all session on the device.
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 r.	 Navigate to Monitor > Services > SDWAN > Aggregate Traffic.

 s.	 Select the SPHUB-NEW device from the drop down.

This shows the aggregate traffic to the SPHUB-NEW device. Here you can view the sent/received packets, and over 
which tunnels the traffic was sent.

 t.	 Navigate to Monitor > Services > SDWAN > Policies.

 u.	 From the menus, select Default-Policy to view the statistics.

 v.	 Expand the Default Rule.

 w.	 In the Default Rule select Statistics > Remote Branch > SPHUB-NEW.

The display should indicate that almost all traffic from the local site to the SPHUB-NEW site is through the MPLS 
transport.
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 x.	 Change the drop down to Path State. This will show the path state information between the local site and the SPHUB-
NEW site.

You can see that the path state for the INET Shared transport is currently down. This is because the local site does 
not have the Shared transport configured. It is only configured on the SPHUB-NEW site.
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 y.	 Navigate to the Monitor > Services > SDWAN > Sites dashboard. This will display the sites that have been discovered 
by the B01 device.

 z.	 Click the arrow next to the Controller-01 device to view site information.

 aa.	Expand the SPHUB-NEW site to view information about the SPHUB-NEW site.
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 ab.	Navigate to the Monitor > Services > SDWAN > SLA Metrics dashboard.

 ac.	Select site SPHUB-NEW from the drop down menu.

This displays the SLA statistics for each path. Note that many values are 0 because the lab environment has very 
low delay, jitter, and latency.

 ad.	Select the SLA Paths tab to display path information.

 ae.	Select the SPHUB-NEW device from the drop down menu.

This displays the current path properties between the local site and the SPHUB-NEW site.
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 af.	 Navigate to Monitor > Services > SDWAN > Transport Paths.

 ag.	Select the SPHUB-NEW device from the drop down menu.

This displays all of the transport paths between the sites and the type of tunnel encapsulation on each path.
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 ah.	Navigate to Monitor > Networking > Interfaces. The Physical Interfaces should be selected by default.

 ai.	 In the interfaces table, expand the vni-0/0.0 interface to view the interface properties.

 aj.	 Select Virtual Interfaces from the drop down menu. This displays the tunnel interfaces on the system.
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 ak.	Select Dynamic Tunnel Interfaces from the drop down menu. This displays the dynamic tunnels that have been created 
between sites.

 al.	 Navigate to Monitor > Networking > Routes, then select the Student-LAN-VR from the drop down. This will display the 
routes in the Student-LAN-VR routing table.

Note the routes and next hops of the following:

•	 10.27.13.0/24 > Network connected to the hub site
•	 10.27.1xx.0/24 > LAN connected to the B02 branch. This will vary depending on your organization.
•	 10.27.1xx.0/24 > LAN connected to the local site. This will vary depending on your organization.
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 am.	 Navigate to the Monitor > System dashboard. This displays information about the appliance, its licensing, and the 
processes running on the appliance.

 an.	Scroll down to view the site summary, location, and templates that are associated with the device.
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 ao.	Scroll down to view the overall system status and the license information.

Note that the Mode is Subjugated. This means that the device is attached to and controlled by Versa Director.
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Step 2.	 Explore Versa Analytics

 a.	 Navigate to Director View > Analytics to open the main Analytics dashboard.

 b.	 In the main Analytics dashboard, hover over the chart in the Top sites by bandwidth dashboard. Information about each 
site will pop up in a small chart.



(C) Versa 2025 (C) Versa 2025

Versa Networks Lab Guide:
SD-WAN Configuration and Administration

137

 c.	 In the main Analytics dashboard, hover over the chart in the Top access circuits by bandwidth. Information about each 
circuit will be displayed.



(C) Versa 2025

Versa Networks Lab Guide:
SD-WAN Configuration and Administration

138

 d.	 Navigate to Dashboard > SD-WAN > Sites to view site information. This will display information about the sites.

You have the ability to filter or display information by selecting organization, site, and time frame from the drop 
downs at the top of the dashboard.

On charts, you can hover your mouse over the legend items to highlight them, and to grey-out the other items. You 
can click on the items in the legend to activate/deactivate them in the chart.
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 e.	 Select Site Availability to view a history of the site status and availability.

 f.	 Navigate to the Link Availability chart. This shows the link availability in the environment.
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 g.	 In the Sites menu, select SxxB01 to view site specific information, then click on the Usage tab to view site usage.

 h.	 Navigate to the Availability tab. This will display the site availability over time.
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 i.	 Navigate to Access Circuits. This will display historical statistics about the access circuits on branch SxxB01.
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 j.	 Navigate to Users. This will display historical statistics about user sessions. When active directory integration is not 
active, users are displayed by IP address.

 k.	 Click on the magnifying glass next to a user to see more details about that user’s usage. You can scroll down the page 
to see more information about the site.
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When you navigate into a specific set of data, you will have the navigation path listed at the top of the dashboard. 
You can jump back to a previous level by clicking on that level in the navigation path.

 l.	 Click on the SxxB01:Users level of the navigation path to return to the main Users dashboard.

 m.	 Navigate to the Applications dashboard of the SxxB01 site.

This dashboard displays the applications that the user has accessed over time. 
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 n.	 Navigate to the Rules tab. If you have SD-WAN traffic rules in place, the rule usage will be displayed. In the lab 
environment there is only a default rule in place.

The SLA Metrics table displays the SLA information between the sites. Note that in the lab environment many of 
the values are listed at 0, as there is very little delay and jitter within the lab network.
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SLA violations are registered whenever the path parameters between sites fall below configured performance 
thresholds. The SLA Violations dashboard shows an historical view of any SLA path violations.

VRF usage monitors the resources used by each VRF in the system. For each tenant, there is currently a single VRF 
configured (the LAN facing VR).
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 o.	 Select the SPHUB-NEW device from the device drop down menu. This will display the VRF usage information on the 
hub site.

There are multiple VRFs available to the Studentxx organization on the hub site, including the WAN transport 
networks.
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 p.	 Navigate to the Dashboard > Security to view the main security dashboard.

The main security dashboard displays charts of the top activity in the system from a security perspective. You can 
hover your mouse over different charts to see more information, or click on many charts to expand that information. 
Hover over and click on the icmp data in the chart. If you click on the icmp data in the chart, a window opens with 
more information about the chart entry.
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The application specific charts display information about the selected application. Because this is a lab environment, 
and you just started to generate new traffic across the SD-WAN, select Last 12 hours in the time filter.

 q.	 To view firewall information, navigate to the Dashboard > Security > Firewall dashboard.

Firewall information can be displayed based on rules, source and destination addresses and zones, and the 
forwarding class of traffic. Take a few moments to view some of the information available in the Firewall dashboard.
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Historical system health information is displayed in the Dashboard > System dashboards. Subcategories of system information include 
interfaces and the guest VNF information.

 r.	 Navigate to Dashboard > System to view the main system dashboard.

The main appliance health dashboard displays the CPU, memory, disk, and session load over time.

The System > Interfaces dashboard displays historical interface activity over a period of time.
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 s.	 Return to the main System dashboard.

When you click on an appliance name, detailed information about that appliance will be displayed.

 t.	 In the Dashboard > System main dashboard, click on the SxxB01 device in the appliance list.

Detailed information about the appliance health and activity (over time) is displayed.
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System logs, alerts, and alarms are sent to Versa Analytics from VOS devices.

 u.	 Navigate to the Logs > Alarms dashboard.

The alarms and their active/cleared states are listed.

The Charts dashboard displays top alarms and severity in a chart format.

 v.	 Click the Charts tab to view the alarms charts.
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 w.	 Return to the main System dashboard.

When you click on an appliance name, detailed information about that appliance will be displayed.

 x.	 In the Dashboard > System main dashboard, click on the SxxB01 device in the appliance list.

Detailed information about the appliance health and activity (over time) is displayed.
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System logs, alerts, and alarms are sent to Versa Analytics from VOS devices.

 y.	 Navigate to the Logs > Alarms dashboard.

The alarms and their active/cleared states are listed.

The Charts dashboard displays top alarms and severity in a chart format.

 z.	 Click the Charts tab to view the alarms charts.
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The Alarm Summary dashboard displays a summary of alarms over time.

 aa.	Click the Summary tab to open the Alarm Summary dashboard.

 ab.	Hover the mouse over alarms in the chart to see more details.

 ac.	Click on the item in the chart to see further details.
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Step 3.	 Analytics Reporting
Versa Analytics has a report building system built into the platform to generate reports on the data found in Analytics. There are 2 
main functions of the Reporting process: Build and Manage.

Build is used to create reports. Manage is used to view and sort reports and report storage.

 a.	 Navigate to the Reporting > Build dashboard in the left-side menu.

The left side of the Build dashboard allows you to select the type of information you want to add to a report, as well as the way you 
want it displayed.
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Let’s go through the process of building a report template. Each data entry is considered a report that can be added to the final report 
document. The report template can have one or more reports included, which will all be displayed.

 b.	 Start by adding a report that includes the following information:

•	 Service: SDWAN
•	 Report type: Access circuit usage for SDWAN
•	 Chart type: Circle graph
•	 Metrics: Sessions and Bandwidth
•	 Report name: Access circuit usage for SDWAN

Note: Although the pie chart button is highlighted, you will have to click on it directly to activate that chart type.

 c.	 Click the Add & Preview button to add the report and add create preview of the data in the report dashboard.
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 d.	 Let’s add another report with the following information:

•	 Service: Security
•	 Report type: Top applications
•	 Chart type: Column chart
•	 Metrics: Sessions and Bandwidth
•	 Report name: Top applications

Note: Although the pie chart button is highlighted, you will have to click on it directly to activate that chart type.

 e.	 Click the Add & Preview button to add the report and add a preview of the data in the report dashboard.
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Your results should look similar to the example below.

The two reports are combined in a single main report that can be saved and scheduled.

 f.	 Click the Save button in the top right corner to save the report format. This will open the save dialog.

Save the report with the following settings:

•	 Name: Generic Usage Report
•	 Access: Private
•	 PDF Template: Default
•	 Schedule: every 1 hours

 g.	 Click OK when finished to save and schedule the report.

Note that scheduled reports can automatically be emailed to one or more 
user by including their email address in the Email notification recipients 
dialog. For reports to be emailed, the email functions must be enabled 
in the Admin settings.
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Single reports can be reloaded in the load of report dialogue.

 h.	 Click on the Load a report button in the build menu.

When you select a tenant, all of the saved reports for that tenantbecome available in the dropdown.

Note that the saved report is the layout of the report, not the information within the report. In other words, when you load a report, the 
information in the charts and graphs will be updated to reflect current information.

 i.	 Click the Load button to pull the new information into thedashboard. The formatting and layout options will be the 
sameas when you built the report.

 j.	 For a soft copy of the information, click the PDF or CSV buttons in the top right. A soft copy will download to your 
Downloads folder.
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 k.	 To view copies of previous reports, open the Reporting > Manage dashboard.

Completed reports are reports that have been previously run, or that have run according to a report schedule.

 l.	 Click on Completed Reports to see if any reports are present in the system.There should be at least one report (the one 
that you ran).

You can delete the reports by clicking on the menu button on the top right, or by clicking the Delete button next to the report.

 m.	 Click the Delete button next to the report that you created to remove it from the system.
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The Saved Reports dashboard contains the saved report layouts that you can load in the Load Report screen. You can manage the 
different layouts from the Saved Reports dashboard.

You can schedule or delete the reports by clicking the menu button at the top right of the dashboard.

 n.	 Check the box next to your saved report, then click the Menu button and select Delete to delete the report.
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 o.	 Return to the Completed Reports page and ensure that any completed reports in the system are removed.

STOP! When you have finished exploring the Monitor and Analytics dashboards,
notify your instructor that you have completed this lab.

STOP
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DIAGNOSTIC TOOLS
The Versa Networks lab environment consists of a fixed, pre-configured topology that will allow you to explore, configure, and 
manage Versa Networks CPEs by using Versa Director, the central management and orchestration platform for a Versa Secure SD-
WAN solution. After completing this lab, you will be able to:

•	 Use the PING tool from Versa Director to perform connectivity tests;
•	 Use the Trace tool from Versa Director to perform connectivity tests;
•	 Use the Versa Speedtest function to verify circuit speeds.

In this lab you will be assigned two CPE devices (Branch devices) for configuration and monitoring. The branch devices are named 
after the student ID that you have been assigned.

The lab environment is accessed through Amazon Workspaces. Your student ID and workspace will be assigned by the instructor.

The remote desktop connection opens a remote workstation, where you will use various tools to navigate and configure the lab 
environment. The main tool you will use in this lab is Versa Director. Versa Director can be accessed by opening the Google Chrome 
browser on the Remote Desktop. The IP address of the Versa Director (from the remote workstation) is 10.27.1.10. Once you begin the 
lab, you may want to create a bookmark to Versa Director in the web browser on the remote desktop.

During certain lab parts, the lab guide will present sample output from the GUI or the CLI. The sample outputs are SAMPLES and 
represent the information as it appeared during the lab guide creation. Your output may vary in some ways (some devices may or may 
not be present, some routes may or may not be the same, etc.) Do not be alarmed if your results vary slightly from the results shown in 
the lab guide. The important thing is that the lab functions in the desired manner.

This lab guide will step you through some common tasks that are performed on Versa Director. After an introductory set of exercises, 
you will be asked to perform some basic tasks that will allow you to become more familiar with the environment.

The goal of this and all lab exercises is to help you gain additional skills and knowledge. Because of this, the lab guide contains 
additional instruction to supplement the student guides.

Now that we’ve discussed what is expected, let’s get started!
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Step 1.	 The Ping Utility
The PING utility is a tool used to verify IP connectivity between devices. It works by sending an ICMP echo request packet to a 
remote system, which the remote system responds to. Information such as reachability and delay metrics can be gathered. It should 
be noted that the PING utility is used for basic connectivity verification and is not used for more complex troubleshooting scenarios, 
although it is frequently one of the first connectivity tests used to verify if a remote host is reachable.

In this exercise you will use the built-in PING utility in the Versa Operating System.

 a.	 In Versa Director, navigate to Appliance View.

 b.	 In Appliance View, click on your SxxB01 device

 c.	 In the Appliance View of your SxxB01 device, navigate to Monitor > Tools.

 d.	 It is located in the Appliance View > Monitor > Tools dashboard.

You will use the PING tool to test connectivity to the LAN segment attached to the SPHUB-NEW device, and to test connectivity to 
the WAN interface on the SPHUB-NEW device.
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 e.	 In the Tools dashboard, click on the Run Ping tab.

 f.	 In the Run Ping tab, enter:

•	 Host Name/Address: 10.27.13.10 (the IP address connected to the SPHUB-NEW Shared network);
•	 Routing Instance: Student-LAN-VR (your local LAN VRF); and
•	 Source Address: This will populate automatically as the local LAN address.

 g.	 Click the Start button. The Latest Results box will not populate until the PING test is finished (about 10 seconds).
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Next you will test reachability to the WAN port on the hub device.

 h.	 Enter the following information in the Run Ping dialog:

•	 Host Name/Address: 10.27.11.100
•	 Routing Instance: INET-Transport-VR
•	 Source Address: This will auto-populate

 i.	 Click the Start button to begin the test.
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Next you will use the Traceroute tool to check reachability to a public destination.

 j.	 Click on the Run Traceroute tab.

 k.	 In the Run Traceroute dialog, enter the following information:

•	 Target Host Name/Address: 8.8.8.8
•	 Routing Instance: INET-Transport-VR
•	 Source IP: This will auto-populate

 l.	 Click the Start button to begin the test.
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Next you will use a domain name to run the traceroute function.

 m.	 In the Run Traceroute dialog, enter the following information:

•	 Target Host Name/Address: www.google.com
•	 Routing Instance: INET-Transport-VR
•	 Source IP: This will auto-populate

Click the Start button to begin the test. This test should fail with an error.

This failure is because the virtual router (INET-Transport-VR) does not have a DNS server configured and therefore cannot look up 
the FQDN of www.google.com. We will now resolve this issue and run the test again.

 n.	 Navigate to Configuration > Others > System > Domain Name Servers.

The current DNS server entry is only for the versa-speedtest routing instance. You need to add a DNS server to the INET virtual router 
if you are going to request DNS lookups in that router.
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 o.	 Click on the +Add button to add a new DNS server. Use the information below.

 p.	 Click the OK button to add the DNS server to the INET-Transport-VR.

 q.	 After you have added a DNS server to the INET-Transport-VR, return to the Monitor > Tools > Run Traceroute dialog.

 r.	 Run the Traceroute function again with the hostname www.google.com. The test should succeed now.
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Next you will run the TCP Dump application to perform a packet capture. The remote testing host does not have an application that 
can read the packet capture files, so you will not be able to view the data. An application such as Wireshark is able to read the files in a 
production environment.

 s.	 Navigate to the Run TCP Dump tab.

 t.	 In the Run TCP Dump dialog, enter interface vni-0/2.The number of packets should be pre-populated with a count of 
100. This translates to the Filter in the Filter dialog (-c 100). You can also specify a timeout in seconds. Use the pre-
configured capture filter of 100 packets.

 u.	 Click the Start button to begin the packet capture on the LAN interface.

A default 60 second timer will begin. Once the timer is complete, the dashboard will allow you to download the captured packets.
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Next you will run a speedtest function to test circuit speed.

 v.	 Click on the Run Speed Test tab to open the speedtest dialog.

Speedtest can be run between the VOS device and a Versa Appliance, or to a public speedtest server (if public Internet access is 
available). To use a VOS device as a speedtest server, you must enable the speedtest server function in the appliance Configuration > 
Others > System > Speedtest dashboard.

For this lab you will do a speedtest to a public speedtest server.

 w.	 In the Run Speed Test dialog, click the Internet tab.

 x.	 In the Routing Instance field, enter INET-Transport-VR.

 y.	 Click the Test Speed button to begin the test. The test will take up to 30 seconds to complete.
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 z.	 Return to the Summary screen. In the summary screen you can measure the speed of circuits using the Measure button. 

 aa.	In the Summary screen, click the Measure button on the INET link.

 ab.	Enter the SPHUB-NEW as the Remote Destination, then click OK.

After the test is complete, the results will display in the Bandwidth column.

STOP! Notify your instructor that you have completed this lab.STOP


